Bootstrap/Popper - “export declarations may only appear at top level of a module”

I'm making an app in Heroku using NodeJS and using Bootstrap to create a modal button that opens a couple of input forms and some drop down menus below that button. I tried to import Popper, but ran into an error on deploying the Heroku app:

SyntaxError: export declarations may only appear at top level of a module    popper.js:2439
Error: Bootstrap dropdown require Popper.js (https://popper.js.org)     bootstrap.js:1414:11

I'm importing the scripts with the following code:

<script src="https://code.jquery.com/jquery-3.2.1.js"></script>
<script src="https://cdnjs.cloudflare.com/ajax/libs/popper.js/1.12.5/esm/popper.js"></script>
<script src="/js/bootstrap.js"></script>

Could this be an issue that has to do with how Heroku is handling the scripts, or am I just importing them incorrectly in some fashion?

0 Comment

NO COMMENTS

LEAVE A REPLY

Captcha image